Install Joomla with latest version Mysql

When I install joomla with latest version mysql database I get the following error:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘TYPE=MyISAM CHARACTER SET `utf8`’ at line…

This is because there’s some change with the new version mysql which has replaced TYPE with ENGINE. In order to get it working, we need to edit the mysql file in joomla pack:

1. installation\sql\mysql\joomla.sql
2. installation\sql\mysql\joomla_backword.sql
Replace
TYPE=MyISAM;
with
ENGINE = MyISAM

Then go ahead to install joomla again, it will be working.

Share

- has written 121 posts.


Leave a Reply

You must be logged in to post a comment.